nordvpn logo

Get 70% discount now

"Of all the providers we've tested, NordVPN is the one that gives you the best value for money"

Get NordVPN

-30 day money back guarantee-

How to Setup and Use NordVPN on MikroTik

NordVPN is a good choice for MikroTik.

Editor Choice emblem

NordVPN

Our Score: 9.6

NordVPN and MikroTik

MikroTik and NordVPN are perhaps the perfect combo when it comes to enjoying secure internet connections. The reason for this isn’t far-fetched. While MikroTik provides top-notch browsing hardware, NordVPN ensures you’re always protected with its premium VPN services.

However, setting-up MikroTik and NordVPN to work together may be difficult if you are a first-timer. Fortunately for you, we have decided to help you through this struggle.

In this article, we’ll provide you with a detailed guide on setting up NordVPN for your MikroTik device.

How to setup NordVPN on Mikrotik

Upon the release of MikroTik firmware version v6.45,the manufacturer’s routers now support dialing out an IKEv2 EAP VPN tunnel to a NordVPN server. This guide explains how you can create that tunnel from your MikroTik hardware to NordVPN servers.

Step 1: Access the terminal on your MikroTik hardware (RouterOS) settings.

Step 2: Install the NordVPN root CA certificate into the hardware. This can be done by running the commands highlighted below:

/tool fetch

url=https://downloads.nordcdn.com/certificates/root.der

/certificate import file-name=root.der

Step 3: Afterwards, check out this link to discover the hostname of the recommended server.

Step 4: The next stage is to create the IPsec tunnel. Here, MikroTik advises that you should set up a Phase 1 profile and Phase 2 proposal configurations. This is to avoid interference with current or future IPsec configurations. To do this, enter these commands:

/ip ipsec profile

add name=NordVPN

/ip ipsec proposal

add name=NordVPN pfs-group=none

MikroTik advises its users to establish a new policy group and template rather than the default one. As explained by the manufacturer, this is to separate the new configuration from other ones. Here, enter these commands:

/ip ipsec policy group

add name=NordVPN

/ip ipsec policy

add dst-address=O.O.O.O/O

group=NordVPN proposal=NordVPN src-

address=O.O.O.O/O template=yes

Step 5: When you’re done creating the IPsec tunnel, establish a new mode configuration entry with a ‘no’ responder. This is for inquiry of configuration details from the servers. Enter these commands:

/ip ipsec mode-config

Add name=NordVPN responder=no

Step 6: Next is to establish your peer and identity configurations. Input the following commands, which include your username and password details:

/ip ipsec peer

add address=recommended server exchange-

mode=ike2 name=NordVPN

profile=NordVPN

ip ipsec identity

add auth-method=EAP certificate=”” eap-

methods=eap-mschapv2 generate-

policy=port-strict mode-config=NordVPN

peer=NordVPN policy-template-

group=NordVPN

username=Your NordVPN username

password=Your NordVPN password

Step 7: The next step is to select what you want to be sent to the VPN tunnel. For example, if you have a local network with an address 11.3.9.1/27 connected to your router. You’ll want all your traffic in the network sent over to the VPN tunnel for encryption and security. So, to do this, you need to first create a new Address/Firewall/IP list that includes your local network.

/ip firewall address-list

Add address=11.3.9.1/27 list=local

Afterward, link your newly created Address/Firewall/IP list to mode config configuration:

/ip ipsec mode-config

Set [ find name=NordVPN ] src-address-

list=local

Step 8: Finally, you confirm that the correct source NAT rule is distinctly generated when the VPN tunnel is established.

/ip firewall Nat print

Additional benefits offered by NordVPN

Using NordVPN with your MikroTik device guarantees the safety of your internet data and activities at all times. However, NordVPN’s exclusive service benefits don’t end with excellent security features. The VPN service provider offers other advantages that promises you a premium web-experience.

Here are some of them:

1. Unlimited web access

MikroTik opens you up to a world of effortless access on the internet. Even so, sometimes, your favorite content may be out of your reach. Often, this is due to issues like censorship and geographical restrictions.

However, with NordVPN, you never have to bother about these issues. One of NordVPN’s premium features is that you can connect to any of its globally located servers. With the rich server base, getting rid of problems such as censorship and geographical restrictions become easier.

2. Multi-device compatibility

Some VPN providers restrict their users to a particular type of device. However, NordVPN is not one of such VPNs.

The provider ensures its services and products are compatible with all your gadgets, including PCs, routers, smartphones. In fact, NordVPN has proxy extensions for your popular browsers. It also allows you to simultaneously access its services from six devices using a single subscription account.

3. 24/7 customer support

VPNs are vital in ensuring your digital safety at all times. Therefore it is essential that you have their services working at the best levels whenever you need them. This also highlights the importance of a reliable customer support system that will assist you whenever your services may be down.

Surprisingly, several alternative VPN providers do not pay attention to this aspect and have low-functioning customer support. However, that’s not the case for NordVPN. The VPN provides you with round-the-clock customer support that you can communicate with using a Help Center, Live Chat, and Email.

In conclusion

Now that you know the steps involved in setting up NordVPN for your MikroTik device, it is only right that you kick-start your new internet experience. However, this is only possible if you are subscribed to one of NordVPN’s plans. If you’re not, there’s not much to worry about as NordVPN has many plans for you to choose from.

First is the ‘exclusive deal,’ which is NordVPN’s 3-year plan. It comes at a rate of $3.49 per month and is regarded as the best offer from the VPN providers. Next is the 2-year plan, which is charged at $4.99 per month. Then there’s the 1-year plan, which comes at a rate of $6.99 per month. Lastly, you can also get the NordVPN monthly plan, which is priced at $11.95 per month.

NordVPN offers a 30-day money-back guarantee on all plans purchased. This is another way by which the VPN provider ensures you get the best results on all its products. So, you can get a refund if you’re dissatisfied with the VPN’s services on your MikroTik hardware. As NordVPN is a top-notch VPN, we don’t see that happening.